Debian 7 требуется разовое администрирование

Печать / RSS
21


Оранжевые штаны
0
Всем привет!
Требуется разовое администрирование Debian 7, а именно требуется установить PHP 5.4.38 (именно ее)
Проблема в том что вчера вышло обновление 5.4.39, при его установке слетела добрая половина всех плагинов(таких как php5-apc, php5-xdebug и плагины от ispmanger'а), теперь требуется откатить PHP на прежнюю версию или установить их(сам я не допер как это сделать, все перерыл, гугл забанил на сутки)

В общем, если вы системный администратор или у вас есть такой знакомый, просьба написать в ICQ, а я уже в теме сообщу найден исполнитель или нет.
X

Пришелец
0
Если надо установить модули к пхп - я могу сделать (в принципе с этим любой справится, если вникнет).

Оранжевые штаны
0
2. xSofa,
apt-get install php5-xdebug
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
php5-xdebug : Depends: php5-common (= 5.4.38-1~dotdeb.1) but 5.4.39-0+deb7u1 is to be installed
E: Unable to correct problems, you have held broken packages.
Репы подчищал, делал принудительную установку 5.4.38, ставился, но при установке модулей опять обновлялся до 5.4.39
Справишься?
X

Пришелец
0
Думаю да, там ведь можно запретить обновление пакета
X

Пришелец
0
WmLiM (21 Марта 2015 / 19:41)
Всем привет!
Требуется разовое администрирование Debian 7, а именно требуется установить PHP 5.4.38 (именно ее)
Проблема в том что вчера вышло обновление 5.4.39, при его установке слетела добрая половина всех плагинов(таких как php5-apc, php5-xdebug и плагины от ispmanger'а), теперь требуется откатить PHP на прежнюю версию или установить их(сам я не допер как это сделать, все перерыл, гугл забанил на сутки)

В общем, если вы системный администратор или у вас есть такой знакомый, просьба написать в ICQ, а я уже в теме сообщу найден исполнитель или нет.
А не 5.6 последняя php? Или на дебиан свои заморочки с этим?
Несколько раз посмотрел на указанную версию и дату топа D

Оранжевые штаны
0
4. xSofa, общение через iCQ, я ввожу твои команды и в ответ пишу тебе лог. Ок?

Добавлено через 04:45 сек.
5. xWAPx, вообще их четыре(более используемых) ветки 5.3 5.4 5.5 5.6
Изменил: Антон (21.03.2015 / 22:18)
X

Пришелец
0
3. WmLiM, это извращение, если честно. Поставь aptitude, это такая плюшка для управления пакетами, установи модуль нужной версии и запрети ему автообновление. Как все это сделать - полно информации, сам в свое время по гайдам всяким лазил.

Оранжевые штаны
0
Путем тыка и какой то консоли решил проблему, вспомнил что можно ставить пакетами приложения, и все оказалось именно так.
dpkg --install имя_пакета.deb

Пфф весь конфиг себе переломал из за этого косяка......
Для выполнения действия необходимо авторизоваться!
Стикеры / Теги / Правила / Топ тем / Топ тем / Поиск