PHP прекращает поддержку расширения MySQL

В прошлые выходные Филип Олсон отправил в список рассылки php-internals предложение о начале постепенного ухода от расширения mysql в будущих версиях php. Это, однако, не означает, что mysql уже не будет в PHP 5.4, но с версии 5.5 уже начнётся работа по обновлению документации и добавлению E_DEPRECATED ошибок к функциям mysql.

В качестве замены предпологается использовать расширение mysqli или PDO, а возможно mysqlnd.

В результате, в будущих версиях PHP5 (начиная с 5.5 или 5.6) вызовы таких функций, как mysql_pconnect, mysql_query и так далее будут пораждать весьма неприятные уведомления E_DEPRECATED, а уже в версии PHP 6 код этих функций будет, скорей всего, полностью удалён из PHP.
Добавил:
Рейтинг: 0
Последние комментарии
N

Чатланин
Дмитрий (15 Июля 2011 / 19:36)
Может вам ещё и ereg жалко?)
Конечно жалко, я бывает по ночам кричу во сне)))))
S

Чатланин
О ужос...
S

Чатланин
Альтернатива mysql_result()
function mysqli_result($query, $key = 0) {

$row = mysqli_fetch_row($query);
return $row[$key];

}

Землянин
интересно узнать источник...

Пришелец
че за MySQLi ? мускули ***ь
Все комментарии (41) »