Обновление версии php с 5.3 до 5.5 на ВДС

Печать RSS
173

M
Автор
Чатланин
0
У меня вдс,версия php 5.3. Так получается,что эта версия устаревает,ну или уже морально устарела.Сейчас даже бесплатные CMSки требуют php не ниже 5.4.
У меня на вдс есть сайты.Хочу обновить php до 5.5.
Вопросы :Можно ли обновить php если на vds уже есть сайты?И как это может отразится на их работе?Спасибо.

Господин ПЖ
0
Ну ничего сложного обновись в зависимости от ОС но могут перестать работать скрипты так что если сайтов много возьми ещё 1 вдс и переноси

Оранжевые штаны
0
1. markiz, в начале возьми поставь тот же OpenServer, в настройках задай требуемую версию пхп и проверь будет ли работать, а потом уже как сказал админ, берёшь вторую вдс и ставишь уже там свежий софт и по одному сайту переносишь туда, попутно указывая вначале ип нового вдс и домена в hosts, дабы самому вначале проверить работу, а потом уже менять днс записи для всего инета.

Пацак
0
если панель isp можно обновить прямо с нее
M
Автор
Чатланин
0
Vantuz , WmLiM ,спасибо!
bygoodvin,а по подробней можно?

Оранжевые штаны
0
5. markiz, при заказе сервера указываешь OC Debian 7 64 min(к примеру), как все создалось идешь думаешь о лицензии, как решишь с лицензией читаешь вот это
Установка ISPManager 5
Изменил: Антон (04.05.2015 / 10:27)

Чатланин
0
Ну тогда уже обновляй сразу до 5.6
Ну и как уже сказали нужно проверить на локалке. Высока вероятность, что некоторые функции сайтов перестанут работать. В php5.4 и 5.5 были удалены некоторые устаревшие функции. Поэтому, если такие имеются в коде сайтов, то их нужно будет заменить.

Оранжевые штаны
0
7. rastoman, 100% не заработает при повышении версии, я с 5.4 переезжал на 5.6 и после этого ни один сайт не захотел работать.

Пацак
0
5. markiz, При наличии ISPmanager 5

Все действия осуществляйте из панели (модуль "Программное обеспечение"):
1. жмем кнопку "Обновить" в модуле "Программное обеспечение" (включить флаг "Обновить список доступного ПО" при этом)
2. выделяем "PHP" и жмем "Удалить", а после "Установить", выбрать php версии 5.... почитай
Изменил: николай (04.05.2015 / 10:52)
Стикеры / Теги / Правила / Топ тем / Топ постов / Поиск