помогите

Печать / RSS
0
1. bublikja 07.12.2016 / 13:03
Пришелец
как это исправить

Deprecated: mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in /home/u518619718/public_html/includes/db.php on line 2
0
2. Сергей 07.12.2016 / 14:32
Пришелец
bublikja,
Устаревшие: mysql_connect (): Расширение MySQL является устаревшим и будет удален в будущем: использование MySQLi или PDO вместо того,
0
3. Даня 07.12.2016 / 16:25
Землянин
Есть три варианта:
1. Понизить версию php (самый лёгкий вариант)
2. Перейти на mysqli (давно пора)
3. Отключить показ Deprecated ошибок (самый плохой вариант)
Изменил: Даня (07.12.2016 / 16:25)
0
4. Удаленный 07.12.2016 / 17:37
Дух
Какой на*** mysqli? Надо юзать PDO
0
5. ramzes 07.12.2016 / 17:41
2000 лет д.н.э.
Какой на*** mysqli? Надо юзать PDOfrasi (Сегодня / 17:37)

аргументируй)))))) ИМХОтеп
0
6. Владимир 07.12.2016 / 18:27
Пацак
+ за PDO. Немного конечно придется подкорректировать запросы с использованием Prepared Statements.
Но судя по ТС - самый простой вариант понизить PHP ).gif хотя хостер врядли ради него это сделает ).gif

Добавлено через 04:44 сек.
Какой на*** mysqli? Надо юзать PDOfrasi (Сегодня / 17:37)
аргументируй)))))) ИМХОтепramzes (Сегодня / 17:41)frasi (Сегодня / 17:37)


Насколько мне известно то mysqli тоже скоро будет Deprecated
Изменил: Владимир (07.12.2016 / 18:31)
0
7. bublikja 07.12.2016 / 19:16
Пришелец
Это на хостингере
0
8. Удаленный 07.12.2016 / 20:01
Дух
ramzes, погоди, ты всерьез сомневаешься в преимуществах пдо перед мускли? Или ты полюбил спорить со мной?)) Или юзаешь/дописываешь скрипты на мускли и у тя слегка бомбануло от моего поста?))

Добавлено через 05:04 сек.
Это на хостингереbublikja (Сегодня / 19:16)

А разве там нельзя менять версию пхп в настройках? Поставь 5.2 и не парься)
0
9. ramzes 08.12.2016 / 05:06
2000 лет д.н.э.
ramzes, погоди, ты всерьез сомневаешься в преимуществах пдо перед мускли? Или ты полюбил спорить со мной?)) Или юзаешь/дописываешь скрипты на мускли и у тя слегка бомбануло от моего поста?))

Добавлено через 05:04 сек.
Это на хостингереbublikja (Сегодня / 19:16)
А разве там нельзя менять версию пхп в настройках? Поставь 5.2 и не парься)frasi (Вчера / 20:01)bublikja (Сегодня / 19:16)

Ты аргументируй, а не вопросом отвечай.
Чума, откуда такая информация?
0
10. bublikja 08.12.2016 / 07:31
Пришелец
frasi, посмотрю
Для выполнения действия необходимо авторизоваться!
Стикеры / Теги / Правила / Топ тем / Топ тем / Поиск